pcxFirefox 49.0.1 is Released

Follow official edition changes
Download pcxFirefox

Built using VC2015 since this edition.

Compatible Changes different from Official Edition
1) Remove the plugin restriction in x64 edition ( back out Bug 1165981 )
2) Restore distribution/bundles support ( back out Bug 1144127 )
3) Restore general.useragent.override.[domain] support ( back out Bug 896114 )

Add two about:config
1) pref(“pcxfirefox.processpriority.firefox.timer”, 30);
Delayed time : seconds
2) pref(“pcxfirefox.processpriority.firefox.level”, 1);
Level 0 NORMAL_PRIORITY_CLASS
Level 1 ABOVE_NORMAL_PRIORITY_CLASS
Level 2 HIGH_PRIORITY_CLASS

About disable extension signing check
Because of Mozilla some changes ( I haven’t worked it out yet ), if you migrate from the same official edition to my build, you can’t enable the disabled unsigned extensions, when you notice that, you can enter about:config and toggle xpinstall.signatures.required option some times, then the disabled extensions will be enabled. If you update your edition from my older build, you don’t need toggle the option.

Advertisements

pcxFirefox 49.0 with new tmemutil module

Follow official edition changes
Download pcxFirefox

Built using VC2015 since this edition and package the new tmemutil module : https://pcxfirefox.wordpress.com/2016/09/22/tmemutil-for-pcxfirefox-20160922/

Compatible Changes different from Official Edition
1) Remove the plugin restriction in x64 edition ( back out Bug 1165981 )
2) Restore distribution/bundles support ( back out Bug 1144127 )
3) Restore general.useragent.override.[domain] support ( back out Bug 896114 )

Add two about:config
1) pref(“pcxfirefox.processpriority.firefox.timer”, 30);
Delayed time : seconds
2) pref(“pcxfirefox.processpriority.firefox.level”, 1);
Level 0 NORMAL_PRIORITY_CLASS
Level 1 ABOVE_NORMAL_PRIORITY_CLASS
Level 2 HIGH_PRIORITY_CLASS

About disable extension signing check
Because of Mozilla some changes ( I haven’t worked it out yet ), if you migrate from the same official edition to my build, you can’t enable the disabled unsigned extensions, when you notice that, you can enter about:config and toggle xpinstall.signatures.required option some times, then the disabled extensions will be enabled. If you update your edition from my older build, you don’t need toggle the option.

pcxFirefox 49.0 is Released

Follow official edition changes
Download pcxFirefox

Built using VC2015 since this edition.

Compatible Changes different from Official Edition
1) Remove the plugin restriction in x64 edition ( back out Bug 1165981 )
2) Restore distribution/bundles support ( back out Bug 1144127 )
3) Restore general.useragent.override.[domain] support ( back out Bug 896114 )

Add two about:config
1) pref(“pcxfirefox.processpriority.firefox.timer”, 30);
Delayed time : seconds
2) pref(“pcxfirefox.processpriority.firefox.level”, 1);
Level 0 NORMAL_PRIORITY_CLASS
Level 1 ABOVE_NORMAL_PRIORITY_CLASS
Level 2 HIGH_PRIORITY_CLASS

About disable extension signing check
Because of Mozilla some changes ( I haven’t worked it out yet ), if you migrate from the same official edition to my build, you can’t enable the disabled unsigned extensions, when you notice that, you can enter about:config and toggle xpinstall.signatures.required option some times, then the disabled extensions will be enabled. If you update your edition from my older build, you don’t need toggle the option.

tmemutil for pcxfirefox 20150517 VC2015 build

tmemutil module source code is hosted in https://bitbucket.org/xunxun/tmemutil-3rd

Full edition: https://sourceforge.net/projects/pcxfirefox/files/Portable/pcxfirefox/tmemutil-pcxfirefox-20150517-vc2015.7z/download

Depending on http://stackoverflow.com/questions/32740172/unresolved-stdio-common-vsprintf-s-what-library-has-this/35789803, if built by VC2015, mini crt should be added _NO_CRT_STDIO_INLINE to CFLAGS.